Apache JServ Distribution

This directory contains the latest Apache JServ source and binary distributions.

NOTICE:
This archive is maintained purely for historic purposes. The Java Apache Project ceased its devlopment in 1999 and all codebases were moved or superseeded by those found at the Apache Jakarta Project or Apache XML Project.

Icon  Name                             Last modified      Size  Description
[PARENTDIR] Parent Directory - [DIR] old/ 2002-06-26 10:41 - [   ] ApacheJServ-1.1.1-1.i386.rpm 2000-05-19 02:01 577K [   ] ApacheJServ-1.1.1-1.i386.rpm.md5 2000-05-19 17:27 70 [   ] ApacheJServ-1.1.1.exe 2000-05-19 13:32 1.1M [   ] ApacheJServ-1.1.1.exe.md5 2000-05-19 17:27 63 [   ] ApacheJServ-1.1.2-1.i386.rpm 2000-06-19 20:07 575K [   ] ApacheJServ-1.1.2-1.i386.rpm.md5 2000-06-22 23:09 70 [   ] ApacheJServ-1.1.2-1.src.rpm 2000-06-17 21:15 846K [   ] ApacheJServ-1.1.2-1.src.rpm.md5 2000-06-17 22:28 69 [   ] ApacheJServ-1.1.2-2.exe 2000-07-03 01:10 1.1M [   ] ApacheJServ-1.1.2-2.exe.md5 2000-07-05 21:17 65 [   ] ApacheJServ-1.1.2.tar.gz 2000-06-17 19:08 753K [   ] ApacheJServ-1.1.2.tar.gz.md5 2000-06-17 19:08 66 [TXT] MOD_SSL-README.txt 2000-01-25 19:11 274 [TXT] md5.sh 1999-10-25 23:26 539 [TXT] md5.txt 2000-01-28 08:07 774

NOTE:
Because of issues with the way that DLL's work, Apache JServ 1.0b5 and higher on NT will only work with Apache 1.3.4 or higher.

NOTE:
UNIX users should download the "tar.gz" distribution and win32 users should download the self-installing "exe" distribution because each package contains specific information for the target operating system. If you have C->.dll compiler on win32, you can always compile the .dll yourself.

The package contains both the Apache JServ servlet engine and the web server modules needed by the web server to communicate with the servlet engine (mod_jserv).

WARNING:
Due to legal restrictions in the Sun Servlet API (JSDK) license, we currently do not ship the JSDK classes in the distributions. For this reason you have to download them separately from the Sun JSDK web site. Currently only version 2.0 of the JSDK is supported.

Notes on Apache JServ Version 0.9.x
Apache JServ 0.9.1 through 0.9.9 require JDK 1.1 and JSDK 1.0 through JSDK 2.0. (Note that Version 0.9.8 was never released.) mod_jserv requires Apache 1.2.0 or newer. Apache JServ versions after 0.9.10 require JDK 1.1 or later. For support reasons, users of Apache JServ 0.9.x should upgrade to version 1.0b5 or higher.