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Part |. Setting up the environment






Chapter 1. Setup

The goal of this chapter of the tutorial isto install (or check that you already have installed) a minimally
needed set of software to build a Cayenne application.

Install Java

Obviously, JDK hasto be installed. Cayenne 3.1 requires JDK 1.5 or newer.

Install Eclipse IDE and the Maven Plugin

Download Eclipse. Thistutoria is based on the Galileo package (Eclipse 3.5), JEE edition, still it should
work with any recent vanilla Eclipse distribution.

After downloading Eclipse, unpack it somewhere in the filesystem, and start it. The only plugin that

you need for the tutorial is m2eclipse. To instal it, in Eclipse go to "Help > Install New Software”,

then click on "Add.." to add a new download site, and enter "Maven" in the "Name" field, and "http://
m_2eclipse.sonatype.org/sites/m2e" in the "Location” field. Y ou may install any of the optional components
that you think you need, but for this tutorial we only select afew basic components as shown on the
following screenshot:



Install Eclipse IDE
and the Maven Plugin

Available Software
Check the items that you wish to install.
Work with: [http:ffmzeclipse.sonatype.org;sites.!mZe H | Add... )
Find more software by working with the "Available Software Sites” preferences.
'_’t\,rpe filter text \l
|Name |Version |
E ¥ 00 Maven Integration for Eclipse
™ L Maven Integration for Eclipse (Required) 0.12.1.20110112-1712
( Select All ) ( Deselect All ) 1 item selected
Details
E Show only the latest versions of available software "] Hide items that are already installed
E Group items by category What is already installed?
E Contact all update sites during install to find required software
@ ( < Back j M ( Cancel ) ( Finish j
A

From here follow the Eclipse dialog instructions to finish the installation.
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Chapter 2. Starting a project

The goal of this chapter isto create anew Java project in Eclipse containing a basic Cayenne mapping. It
presents an introduction to CayenneModeler GUI tool, showing how to create the initial mapping objects:
DataDomain, DataNode, DataM ap.

Create a new Project in Eclipse

In Eclipse select "File > New > Other..." and then "Maven > Maven Project”. Click "Next". On the following
screen check "Create a simple project” checkbox and click "Next" again. In the dialog shown on the
screenshot below, fill the "Group I1d" and "Artifact Id" fields and click "Finish".

MmO New Maven Project

MNew Maven project =
Configure project M
Artifact
Croup Id: .Drg.example.cavenne Z]

Artifact Id: | tutorial

|

Version: | 0.0.1-SNAPSHOT -

Packaging: .jar E]

Mame: [ E]
Description:

Parent Project

Croup Id: [ Z]

Artifact Id: | =l
Version: [ E] [ Browse... | Clear
b Advanced
() ( Back ) [ N ) ( cancel ) (& Finish )
L) L < Bac I Bxt > I ance ) inis
P




Download and Start
CayenneM odeler

Now you should have a new empty project in the Eclipse workspace. Check that the project Java compiler
settings are correct. Rightclick on the "tutorial” project, select "Properties > Java Compiler” and ensure that
"Compiler compliance level" is at least "1.5" (some versions of Maven plugin seem to be setting it to 1.4 by
default).

Download and Start CayenneModeler

Although later in this tutorial we'll be using Maven to include Cayenne runtime jarsin the project, you'll till
need to download Cayenne to get access to the CayenneModeler tool.

-

[

If you are redlly into Maven, you can start CayenneModeler from Maven if you wish. We'll doitina
more traditional way here.

Download the latest release. Unpack the distribution somewhere in the file system and start
CayenneM odeler, following platform-specific instructions. On most platformsit is done simply by
doubleclicking the Modeler icon. The welcome screen of the Modeler 1ooks like this:

[El=]al (=] [+ mal[¢[e] o]+ MM @ ea][c[>] sen

Recent Projects:
| g

New Project Open Project




Create a New Mapping
Project in CayenneM odeler

Create a New Mapping Project in
CayenneModeler

Click on the "New Project”" button on Welcome screen. A new mapping project will appear that contains a
single DataDomain. The meaning of a DataDomain is explained elsewhere in the User Guide. For now it is
sufficient to understand that DataDomain is the root of your mapping project.

Create a DataNode

The next project object you will createis a DataNode. DataNode is a descriptor of a single database your
application will connect to. Cayenne mapping project can use more than one database, but for now, welll
only use one. With "project” selected on the left, click on "Create DataNode" button on the toolbar (or select
"Project > Create DataNode" from the menu.

A new DataNode is displayed. Now you need to specify JDBC connection parameters. For an in-memory
Derby database you can enter the following settings:

» JDBC Driver: org.apache.derby.jdbc.EmbeddedDriver

» DB URL: jdbc:derby:memory:testdb;create=true

v |We are creating an in-memory database here. So when you stop your application, all the datawill be
lost. In most real-life cases you'll be connecting to a database that actually persistsits data on disk, but
an in-memory DB will do for the simple tutorial.

Also you will need to change " Schema Update Strategy". Select
"org.apache.cayenne.access.dbsync.Createl fNoSchemaStrategy” from the dropdown, so that Cayenne creates
anew schema on Derby based on the ORM mapping when the application starts.



Create a DataM ap

.00

* - CayenneModeler - [New]

Cleld [*] [+ mla[C/v [o]+] @@ eea[c]]

Search:

& project

B starooe|

[ Main | Adapter  Password Encoder ]

DataMode Configuration

DataMode Name:

Schema Update Strategy:

Local DataSource (opt.):

DataSource Factory:

JDBC Configuration

JDBC Driver:

DB URL:

datanode

apache.cayenne.access.dbsync.SkipSchemalUpdateStrategy j

You can enter custom class implementing Schemall pdateStrategy

| Select DataSource for Local Work...

CRe

ayenne.configuration.server.XMLPoolingDataSourceFactory j

org.apache.derby.jdbc.EmbeddedDriver

jdbc:derby:memory:testdb;create=true

Username:

Password:

Min Connections:

Max Connections:

( : \
| Sync with Local |

Create a DataMap

Now you will create a DataM ap. DataMap is an object that holds all the mapping information. To create

it, click on "Create DataMap" button (or select a corresponding menu item). Note that the newly created
DataMap is automatically linked to the DataNode that you created in the previous step. If there is more than
one DataNode, you may need to link a DataMap to the correct node manually. In other words a DataM ap

within DataDomain must point to a database described by the map.

Y ou can leave all the DataM ap defaults unchanged except for one - "Java Package". Enter
"org.example.cayenne.persistent”. This name will later be used for all persistent classes.
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Save the Project

an00o * - CayenneModeler - [New]
|[Ble@) [+ elal [@1s] [e]s] @@ [ele]a] [c]=] Search:
& project DataMap
"

> @ datanode DataMap Configuration

DataMap Mame: datamap
File: (no file)
DataNode: | & datanode 4

Quote S0OL Identifiers: [ |

Entity Defaults

DB Schema: Update...

Java Package: org.example.cayenne.persistent ] Update...

Custom Superclass: Update...
Optimistic Locking: [}

Client Class Defaults

Allow Client Entities: [ |

Client Java Package: Update...

Custom Superclass: Update...

Save the Project

Before you proceed with the actual mapping, let's save the project. Click on "Save" button in the toolbar

and navigate to the "tutorial" Eclipse project folder that was created earlier in this section and its "src/main/
resources' subfolder and save the project there. Now go back to Eclipse, right click on "tutorial" project and

select "Refresh”, you will see three Cayenne XML files.

11



Save the Project

TE_;—b'-tutnrial
b src/main/java
|X| cayenne-project.xmi
|X| datamap.map.xml
b B src/test/java
b sro/test/resources
b = JRE System Library [J25E-1.5]
"ﬂ", Maven Dependencies
P = src
b (= target
TE] pom.xml

Note that the location of the XML filesis not coincidental. Cayenne runtime looks for "cayenne-*.xml" file
in the application CLASSPATH and "src/main/resources’ folder should already be a"class folder" in Eclipse
for our project (and is also a standard location that Maven would copy to ajar file, if we were using Maven
from command-line).
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Chapter 3. Getting started with Object
Relational Mapping (ORM)

The goal of this section isto learn how to create a simple Object-Relational model with CayenneModeler.
We will create a complete ORM modé for the following database schema:

ARTIST

ID INTEGER (PK)
NAME VARCHAR(200)
DATE_OF_BIRTH DATE

.I

PAINTING M

ID INTEGER (PK)

NAME VARCHAR(200)
ARTIST_ID INTEGER (FK)
GALLERY_ID INTEGER (FK)

M

GALLERY 1

ID INTEGER (FPK)
NAME VARCHAR(200)

Very often you'd have an existing database already, and it can be quickly imported in Cayenne via

J "Tools > Reengineer Database Schema". Thiswill save you lots of time compared to manual mapping.
However understanding how to create the mapping by hand isimportant, so we are showing the
"manual" approach below.

Mapping Database Tables and Columns

L ets go back to CayenneModel er where we have the newly created project open and start by adding the
ARTIST table. Database tables are called " DbEntities' in Cayenne mapping (those can be actual tables or
database views).

Select "datamap" on the left-hand side project tree and click "Create DbEntity" button (or use "Project >
Create DbEnNtity" menu). A new DbEntity is created. In "DbEntity Name" field enter "ARTIST". Then

13



Mapping Database Relationships

click on "Create Attribute” button on the entity toolbar (third button from the left). This action changes the
view to the "Attribute” tab and adds a new attribute (attribute means a "table column” in this case) called
"untitledAttr". Let'srenameit to ID, makeit an INTEGER and make it a PK:

(s RN ) CavenneModeler ,r'Users!dzmltry,r'tutonal!src,l’malnfresourcesfc.wenne project.xml
EIB. Df_,’ <',’1 Ei% B E @ F ) e Search:
g project [ Entity - Attributes | Relationships |
v o datamap = :

omE | |[CIE[5] (=) [«
» @ datanode Name "?' Type Mandatory |[Max Length|  Scale

O o= T T N N

Similarly add NAME VARCHAR(200) and DATE_OF_BIRTH DATE attributes. After that repeat this
procedure for PAINTING and GALLERY entities to match DB schema shown above.

». | Don't forget to save your project periodically to avoid losing your work. You will also have to refresh
the project in Eclipse after every CayenneModeler save, as Eclipseis by default unaware of any
changes made in the Modeler.

Mapping Database Relationships

Now we need to specify relationships between ARTIST, PAINTING and GALLERY tables. Start by
creating aone-to-many ARTIST/PAINTING relationship:

» Select the ARTIST DbEntity on the left and click on the "Relationships* tab.

 Click on "Create Relationship" button on the entity toolbar (second button from the left) - arelationship
called "untitledRel" is created.

* Choose the "Target" to be "Painting”.

 Click on the "Database Mapping" button (letter "I" in acircle) - relationship configuration dialog is
presented. Here you can assign a name to the relationship and also its complimentary reverse relationship.
This name can be anything (thisis really a symbolic name of the database referential constraint), but it is
recommended to use avalid Javaidentifier, as thiswill save some typing later. Well call the relationship
"paintings"' and reverse relationship "artist”.

14



Mapping Java Classes

» Click on"Add" button on theright to add ajoin
e Select "ID" column for the "Source" and "ARTIST _ID" column for the target.

 Rdationship information should now look like this:

arnm DbRelationship Info: ARTIST to PAINTING

DbRelationship Information

Relationship: paintings

Reverse Relationship | artist]

Joins

Source ¥ Target C Add )

[ Remove |
.

i X L b |
L Done 7 C Cancel )

 Click "Done" to confirm the changes and close the dialog.

» Two complimentary relationships have been created - from ARTIST to PAINTING and back. Still you
may have noticed one thing ismissing - "paintings" relationship should be to-many, but "To Many"
checkbox is not checked. Let's change that - check the checkbox for "paintings' relationship, and
then click on PAINTING DbEntity, and uncheck "artist" relationship "To Many" to make the reverse
relationship "to-one" asit should be.

» Repeat the steps above to create a many-to-one relationship from PAINTING to GALLERY, calling the
relationships pair "gallery” and "paintings’.

Mapping Java Classes

Now that the database schema mapping is complete, CayenneM odeler can create mappings of Java classes
(aka"ObjEntities") by deriving everything from DbEntities. At present there isno way to do it for the entire
DataMap in one click, so welll do it for each table individually.

15



Mapping Java Classes

» Select "ARTIST" DbEntity and click on "Create ObjEntity" button (agreen classicon) either on the
entity toolbar or on the main toolbar. An ObjEntity called "Artist" is created with a Java classfield set
to "org.example.cayenne.persistent.Artist”". The modeler transformed the database names to the Java-
friendly names (e.g., if you click on the "Attributes' tab, you'll seethat "DATE_OF BIRTH" column was
converted to "dateOfBirth" Java class attribute).

* Select "GALLERY" DbEntity and click on "Create ObjEntity" button again - you'll see a"Gallery”
ObjEntity created.

* Finaly, do the same thing for "PAINTING".

Now you need to synchronize relationships. Artist and Gallery entities were created when there was no
related "Painting" entity, so their relationships were not set.

» Click onthe "Artist" ObjEntity and (optinally) change to the "Relationships" tab. Now click on "Sync
ObjEntity with DbEntity" button on the toolbar (two yellow arrows) - you will see the "paintings"
relationship appear.

» Do the samefor the "Gallery" entity.

Unless you want to customize the Java class and property names (which you can do easily) the mapping is
complete.

16



Chapter 4. Creating Java Classes

Here welll generate the Java classes from the model that was created in the previous section.
CayenneModeler can be used to also generate the database schema, but since we specified
"CreatelfNoSchemaStrategy" earlier when we created a DataNode, we'll skip the database schema step. Still
be aware that you can do it if you need to via"Tools > Create Database Schema'.

Creating Java Classes

* Select "Tools > Generate Classes' menu.

» For "Type" select "Standard Persistent Objects’, if it is not already selected.

[

» For the "Output Directory” select "src/main/java’ folder under your Eclipse project folder (thisisa"peer’
location to the cayenne-* .xml location we selected before).

 Click on "Entities" tab and check the "Check All Classes' checkbox (unlessit is already checked and
reads "Uncheck all Classes").

¢ Click "Generate"

Now go back to Eclipse, right click on "tutorial" project and select "Refresh - you should see pairs of
classes generated for each mapped entity. Y ou probably also see that there's a bunch of red squiggles next
to the newly generated Java classesin Eclipse. Thisis because our project does not include Cayenne as a
Maven dependency yet. Let'sfix it now by adding "cayenne-server” artifact in the bottom of the pom.xml
file. The resulting POM should look like this:

<project xm ns="http://maven. apache. org/ POM 4. 0. 0" xml ns: xsi ="htt p://ww. w3. or g/ 2001/ XM_Schema- i nst ance"
xsi : schemaLocati on="http:// maven. apache. org/ POM 4. 0.0 http:// maven. apache. or g/ maven-v4_0_0. xsd" >

<nodel Ver si on>4. 0. 0</ nodel Ver si on>

<gr oupl d>or g. exanpl e. cayenne</ gr oupl d>

<artifactld>tutorial </artifactld>

<ver si on>0. 0. 1- SNAPSHOT</ ver si on>

<dependenci es>
<dependency>
<gr oupl d>or g. apache. cayenne</ gr oupl d>
<artifactld>cayenne-server</artifactld>
<!-- Here specify the version of Cayenne you are actually using -->
<ver si on>3. 1M3</ ver si on>
</ dependency>

</ dependenci es>

</ proj ect >

Y our computer must be connected to the internet. Once you save the pom.xml, Eclipse will download the
needed Cayenne jar file and add it to the project build path. As aresult, all the errors should disappear.

17



Creating Java Classes

AR B % - =7 W _Galleryjava | [J] Datamap.java

?Etutorial package org.example.cayenne.persistent.auto;

¥ (& src/main/java
v _I':-E‘ org.example.cayenne.persistent
> m Artist. java

#import jova.util. Dute;D

=g T
» 1] Datamap java * (lass _Artist was generated by Cavenne.
> 1] Gallery java * T+ is probably a good idea to avoid changing -
b 11| Painting.java * zince it may be overwritten next time code is
!‘EE‘ org.example.cayenne.persistent.auto * Tf you need to make any customizations, pleas
L g m _Artist.java */
» [J] _Datamap.java Wi public abstroct class _Artist extends CayenneDat

L g m _Gallery.java
» 1] _Painting.java
¥ 8 src/main/resources
|X| cayenne-project.xml

public static final String DATE_OF_BIRTH_PRO:
public static final String NAME_FPROPERTY = ™
public static final String PAINTINGS_PROPERT

|%] datamap.map.xmi public static fimal String ID_PK_COLUMN = "II
b B sre/test/java
b [ src/test/resources = public void setDatelfBirth{Dote datelfBirth)
b =i JRE System Library [J2SE-1.5] , writeProperty("dote0fEirth", date0fBirth
T B, Maven Dependencies . .
!:II:;I cayenn:‘isewer—i.lh‘lijar - fUsers/dzmil B public Date getDateOfBirth(d {. : "
= ! return (DatedreadProperty("date0fEirth")
P [ commons-collections-3. 1 jar - [Users/dz }
L g @ commons-logging-1.1.jar - /Users/dzmil
> @ velocity-1.6.3.jar - /Users /dzmitry/.m2/r = public void setMame(String name) {
b (o0 commons-lang-2.4.jar - [Users/dzmitry/ writeProperty("nome", name};
b o oro-2.0.8.jar - fUsers/dzmitry/.m2 /repo: }
'555_" = public S5tring gt_:tName{) { , ,
b & target return (String)readProperty("nome"};
M| pom.xml !

Now let's check the entity class pairs. Each one is made of a superclass (e.g. Artist) and a subclass (e.g.
Artist). You should not modify the superclasses whose names start with"_" (underscore), as they will

be replaced on subsequent generator runs. Instead all custom logic should be placed in the subclassesin
"org.example.cayenne.persistent” package - those will never be overwritten by the class generator.

L]
)

.| Class Generation Hint Often you'd start by generating classes from the Modeler, but at the later stages

of the project the generation is usually automated either via Ant cgen task or Maven cgen mojo. All
three methods are interchangeabl e, however Ant and Maven methods would ensure that you never
forget to regenerate classes on mapping changes, as they are integrated into the build cycle.
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Chapter 5. Getting started with
ObjectContext

In this section we'll write asimple main classto run our application, and get a brief introduction to Cayenne
ObjectContext.

Creating the Main Class

 |n Eclipse create anew class called "Main" in the "org.example.cayenne” package.

* Create astandard "main" method to make it arunnable class:
package org. exanpl e. cayenne;
public class Min {
public static void main(String[] args) {

}
}

» Thefirst thing you need to be able to access the database is to create a ServerRuntime object (which is
essentially awrapper around Cayenne stack) and use it to obtain an instance of an ObjectContext.
package org. exanpl e. cayenne;

i mport org. apache. cayenne. Obj ect Cont ext ;
i nport org.apache. cayenne. configuration. server. Server Runti ne;

public class Main {

public static void main(String[] args) {
Server Runti me cayenneRuntine = new Server Runti me(
"cayenne-project.xm");
bj ect Cont ext context = cayenneRunti me. get Context();

}

ObjectContext isan isolated "session” in Cayenne that provides al needed APl to work with data.
ObjectContext has methods to execute queries and manage persistent objects. We'll discuss them in
the following sections. When the first ObjectContext is created in the application, Cayenne loads XML
mapping files and creates a shared access stack that is later reused by other ObjectContexts.

Running Application
Let's check what happens when you run the application. But before we do that we need to add another

dependency to the pom.xml - Apache Derby, our embedded database engine. The following piece of XML
needs to be added to the <dependencies>...</dependencies> section, where we already have Cayenne jars.

21



Running Application

<dependency>
<gr oupl d>or g. apache. der by</ gr oupl d>
<artifactld>derby</artifactld>
<versi on>10. 8. 1. 2</ ver si on>

</ dependency>

Now we are ready to run. Right click the "Main" classin Eclipse and select "Run As> Java Application”. In

the console you'll see output similar to this, indicating that Cayenne stack has been started:

I NFO
I NFO
I NFO

Loadi ng XM. configuration resource fromfile:cayenne-project.xm
| oadi ng user narme and password.
Created connection pool: jdbc:derby: menory:testdb; create=true

Driver class: org.apache. derby.jdbc. EnbeddedDri ver

M n.
Max.

connections in the pool: 1
connections in the pool: 1

How to Configure Cayenne Logging Y ou can tweak more or less detailed output by following the

instructions in the logging chapter.

Nothing much happened here, but we've been able to create a working Cayenne stack. In the following
chapters we'll use the ObjectContext for more interesting things.
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Chapter 6. Getting started with
persistent objects

In this chapter we'll learn about persistent objects, how to customize them and how to create and save them
in DB.

Inspecting and Customizing Persistent
Objects

Persistent classes in Cayenne implement a DataObject interface. If you inspect any of the classes generated
earlier in thistutorial (e.g. org.example.cayenne.persistent.Artist), you'll see that it extends a class with the
name that starts with underscore (org.example.cayenne.persistent.auto._Artist), which in turn extends from
org.apache.cayenne.CayenneDataObject. Splitting each persistent class into user-customizable subclass
(Xyz) and a generated superclass (_Xyz) is auseful technique to avoid overwriting the custom code when
refreshing classes from the mapping model.

Let'sfor instance add a utility method to the Artist class that sets Artist date of birth, taking a string argument

for the date. It will be preserved even if the model changes later:
package org. exanpl e. cayenne. persi stent;

inmport java.text.ParseException;
inmport java.text.SinpleDateFormat;
import java.util.Date;

inport org.exanpl e. cayenne. persi stent.auto. _Artist;
public class Artist extends _Artist {

static final String DEFAULT_DATE_FORVAT = "yyyyMwid";

/**
* Sets date of birth using a string in format yyyyMwid.
*/
public void setDateOBirthString(String yearMnthDay) {
if (yearMonthDay == null) {
setDateO' Birth(null);
} else {

Dat e date;
try {
date = new Si npl eDat eFor mat ( DEFAULT_DATE_FORVAT)
. par se(year Mont hDay) ;
} catch (ParseException e) {
throw new |1 egal Argunent Excepti on(
"A date argunment nust be in format '"
+ DEFAULT_DATE_FORMAT + "': " + year Mont hDay);
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Create New Objects

setDateCfBirth(date);

Create New Objects

Now welll create a bunch of objects and save them to the database. An object is created and registered with
ObjectContext using "newObject” method. Objects must be registered with DataContext to be persisted and
to allow setting relationships with other objects. Add this code to the "main" method of the Main class:

Artist picasso = context.newlbject(Artist.class);
pi casso. set Nane(" Pabl o Pi casso");
pi casso. setDateOBirthString("18811025");

Note that at this point "picasso" object is only stored in memory and is not saved in the database. Let's
continue by adding a Metropolitan Museum "Gallery" object and afew Picasso "Paintings':

Gal l ery netropolitan = context.newObject(Gallery.class);
nmet ropol i tan. set Name(" Metropol itan Museum of Art");

Pai nting girl = context.newlbject(Painting.class);
girl.setNane("G rl Reading at a Table");

Pai nting stein = context.newlbj ect (Painting.class);
stein.setName(" Gertrude Stein");

Now we can link the objects together, establishing relationships. Note that in each case below relationships
are automatically estabslished in both directions (e.g. picasso.addToPaintings(girl) has exactly the same
effect as girl.setToArtist(picasso)).

pi casso. addToPai ntings(girl);
pi casso. addToPai nti ngs(stein);

girl.setGallery(nmetropolitan);
stein.setGllery(nmetropolitan);

Now lets save all five new objects, in asingle method call:

cont ext. commi t Changes() ;

Now you can run the application again as described in the previous chapter. The new output will show afew
actual DB operations:

or g. apache. cayenne. confi gurati on. XM_Dat aChannel Descri pt or Loader | oad
INFO Loading XM. configuration resource fromfile:cayenne-project.xm

I NFO. Openi ng connection: jdbc:derby: nenory:testdb;create=true

Logi n: null

Passwor d: ***x**x

I NFG +++ Connecting: SUCCESS.

INFO. Detected and installed adapter: org.apache. cayenne. dba. der by. Der byAdapt er

INFO --- transaction started.

INFO No schermm detected, will create mapped tables

I NFO CREATE TABLE GALLERY (1D I NTEGER NOT NULL, NAME VARCHAR (200), PRI MARY KEY (1D))

I NFO CREATE TABLE ARTI ST ( DATE_OF_BI RTH DATE, |D INTEGER NOT NULL, NAME VARCHAR (200), PRI MARY KEY (1D))

I NFO CREATE TABLE PAI NTI NG (ARTI ST_I D | NTEGER, GALLERY_|I D I NTEGER, | D | NTEGER NOT NULL,
NAME VARCHAR (200), PRI MARY KEY (1D))
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I NFO.
I NFO
I NFO

I NFO.
I NFO
I NFO
I NFO
I NFO.
I NFO
I NFO
I NFO
I NFO.
I NFO
I NFO
I NFO
I NFO.
I NFO
I NFO
I NFO
I NFO.
I NFO

ALTER TABLE PAI NTI NG ADD FOREI GN KEY (ARTI ST_I D) REFERENCES ARTI ST (I D)

ALTER TABLE PAI NTI NG ADD FOREI GN KEY ( GALLERY_I D) REFERENCES GALLERY (I D)

CREATE TABLE AUTO_PK_SUPPORT (

TABLE_NAME CHAR(100) NOT NULL, NEXT_ID BIG NT NOT NULL, PRI MARY KEY(TABLE_NAME))
DELETE FROM AUTO_PK_SUPPORT WHERE TABLE _NAME I N (' ARTIST', 'GALLERY', 'PAINTING)

I NSERT | NTO AUTO_PK_SUPPORT ( TABLE_NAME, NEXT_I D) VALUES (' ARTIST', 200)

I NSERT | NTO AUTO_PK_SUPPORT ( TABLE_NAME, NEXT_I D) VALUES (' GALLERY', 200)

I NSERT | NTO AUTO_PK_SUPPORT ( TABLE_NAME, NEXT_| D) VALUES (' PAINTING, 200)

SELECT NEXT_| D FROM AUTO_PK_SUPPORT WHERE TABLE_NAME = ? FOR UPDATE [bind: 1:'ARTIST']
SELECT NEXT_| D FROM AUTO_PK_SUPPORT WHERE TABLE_NAME = ? FOR UPDATE [bind: 1:' GALLERY']
SELECT NEXT_I D FROM AUTO_PK_SUPPORT WHERE TABLE_NAME = ? FOR UPDATE [bind: 1:' PAINTING ]
I NSERT | NTO GALLERY (I D, NAME) VALUES (?, ?)

[batch bind: 1->ID:200, 2->NAVE: ' Metropolitan Miseum of Art']

=== updated 1 row.

I NSERT | NTO ARTI ST (DATE_OF_BI RTH, | D, NAME) VALUES (?, 2, ?)

[batch bind: 1->DATE OF Bl RTH ' 1881-10-25 00: 00: 00. 0', 2->|D: 200, 3->NAME: ' Pabl o Picasso']
=== updated 1 row.

I NSERT | NTO PAI NTI NG (ARTI ST_I D, GALLERY_ID, 1D, NAME) VALUES (?, ?, ?, ?)

[batch bind: 1->ARTIST_ID: 200, 2->GALLERY_I D: 200, 3->ID:200, 4->NAME:' Gertrude Stein']
[batch bind: 1->ARTIST_ID: 200, 2->GALLERY_| D: 200, 3->ID:201, 4->NAME:' Grl Reading at a Table']
=== updated 2 rows.

+++ transaction conmtted.

So first Cayenne creates the needed tables (remember, we used " Createl fNoSchemaStrategy"). Then it runsa
number of inserts, generating primary keys on the fly. Not bad for just afew lines of code.
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Chapter 7. Selecting Objects

This chapter shows how to select objects from the database using SelectQuery.

Introducing SelectQuery

It was shown before how to persist new objects. Cayenne queries are used to access already saved objects.
The primary query type used for selecting objects is SelectQuery. It can be mapped in CayenneModeler or
created viathe API. WEe'l use the later approach in this section. We don't have too much data in the database
yet, but we can till demonstrate the main principles below.

» Select all paintings (the code, and the log output it generates):

Sel ect Query sel ectl = new Sel ect Query(Painting.class);
Li st paintingsl = context.performuery(selectl);

INFO SELECT t0. GALLERY_ID, t0.ARTIST_ID, t0.NAME, tO0.1D FROM PAINTING tO
INFO. === returned 2 rows. - took 18 ns.

» Select paintings that start with "gi", ignoring case:

Expression qualifier2 = ExpressionFactory.|ikel gnoreCaseExp(

Pai nt i ng. NAME_PROPERTY,

"gi %)
Sel ect Query select2 = new Sel ect Query(Painting.class, qualifier2);
Li st paintings2 = context.perfornQuery(sel ect?2);

I NFO. SELECT tO0. GALLERY_ID, t0.NAME, tO0.ARTIST_ID, t0.1D FROM PAI NTI NG t0 WHERE UPPER(t 0. NAME) LI KE UPPER(?)
[bind: 1->NAMVE:'Qi %] - prepared in 6 ms.
INFO === returned 1 row. - took 18 ns.

» Select all paintings done by artists who were born more than a 100 years ago (demonstrating using
Expression.fromString(..) instead of ExpressionFactory):

Cal endar ¢ = new GregorianCal endar ();
c.set(c.get(Cal endar. YEAR) - 100, O, 1, 0O, 0O, 0);

Expression qualifier3 = Expression.fronBtring("artist.dateCGBirth < $date");

qualifier3 = qualifier3.expWthParaneters(Collections.singletonvap("date", c.getTine()));
Sel ect Query sel ect3 = new Sel ect Query(Painting.class, qualifier3);

Li st paintings3 = context.perfornfuery(sel ect3);

I NFO. SELECT tO0. GALLERY_ID, t0.NAME, tO0.ARTIST_ID, t0.1D FROM PAINTINGt0 JON ARTIST t1 ON (t0.ARTIST_ID = t1.1D)
WHERE t 1. DATE_OF_BIRTH < ? [bind: 1->DATE_OF BI RTH: ' 1911-01-01 00: 00: 00.493'] - prepared in 7 ns.
INFO. === returned 2 rows. - took 25 ns.
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Chapter 8. Deleting Objects

This chapter explains how to model relationship delete rules and how to delete individual objects as well as
sets of objects. Also demonstrated the use of Cayenne class to run a query.

Setting Up Delete Rules

Before we discuss the API for object deletion, lets go back to CayenneModeler and set up some delete rules.
Doing thisis optional but will simplify correct handling of the objects related to deleted abjects.

Inthe Modeler go to "Artist" ObjEntity, "Relationships' tab and select "Cascade” for the "paintings’
relationship deleterule:

[ NN * - CayenneModeler - /Users/dzmitry/tutorial /src/main/resources/cayenne-project.xml
= B REIE I I R E EHE I R EE Search:
& project [ Entity = Attributes - Relationships | Callbacks | Listeners |
v o datamap ; _ ]
e artist| AL AHE ABES
® Gallery Name 7 Target Semantics Delete Rule | Used for Locking
[ ARTIST
] GALLERY
[ PAINTING |.

» 3 datanode

Repeat this step for other relationships:

» For Gallery set "paintings' relationship to be "Nullify", as a painting can exist without being displayed in a
galery.

* For Painting et both relationships rules to "Nullify".

Now save the mapping, and refresh the project in Eclispe.

Deleting Objects

While deleting objects is possible via SQL, qualifying a delete on one or more I1Ds, a more common way in
Cayenne (or ORM in general) isto get a hold of the object first, and then delete it via the context. Let's use
utility class Cayenneto find an artist:
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Expression qualifier = ExpressionFactory. mat chExp(Arti st. NAME_PROPERTY, "Pablo Picasso");
Sel ect Query sel ect = new Sel ect Query(Artist.class, qualifier);
Artist picasso = (Artist) Cayenne.object For Query(context, select);

Now let's delete the artist:

if (picasso != null) {
cont ext . del et eCbj ect (pi casso);
cont ext . conmi t Changes();

}

Since we set up "Cascade" delete rule for the Artist.paintings relationships, Cayenne will automatically
delete al paintings of this artist. So when your run the app you'll see this outpult:

I NFO SELECT t 0. DATE_OF_BIRTH, t0.NAME, t0.|D FROM ARTI ST t0
WHERE t 0. NAME = ? [bind: 1->NAME: ' Pablo Picasso'] - prepared in 6 ns.

INFO. === returned 1 row. - took 18 ns.
INFO +++ transaction conmitted.
INFO. --- transaction started.

I NFO. DELETE FROM PAI NTI NG WHERE ID = ?
INFO. [batch bind: 1->ID:200]

INFG [batch bind: 1->|D:201]

INFO. === updated 2 rows.

I NFO. DELETE FROM ARTI ST WHERE I D = ?
INFO. [batch bind: 1->ID:200]

INFO === updated 1 row.

INFO +++ transaction conmitted.

30



Part IV. Converting to Web Application






Chapter 9. Converting to Web
Application

This chapter shows how to work with Cayenne in aweb application.

Converting Tutorial to a Web Application

The web part of the web application tutorial is done in JSP, which isthe least common denominator of the
Javaweb technologies, and is intentionally simplistic from the Ul perspective, to concentrate on Cayenne
integration aspect, rather than the interface. A typical Cayenne web application works like this:

» Cayenne configuiration isloaded when an application context is started, using a special servlet filter.

» User requests are intercepted by the filter, and the DataContext is bound to the request thread, so the
application can accessit easily from anywhere.

» The same DataContext instance is reused within a single user session; different sessions use different

DataContexts (and therefore different sets of objects). The context can be scoped differently depending on

the app specifics. For the tutorial we'll be using a session-scoped context.
So let's convert the tutorial that we created to aweb application:
* In Eclipse under "tutorial" project folder create a new folder "src/main/webapp/WEB-INF".

* Under "WEB-INF" create anew file "web.xml" (a standard web app descriptor):

web.xml

<?xm version="1.0" encodi ng="utf-8"?>
<! DOCTYPE web- app
PUBLIC "-//Sun M crosystens, Inc.//DTD Wb Application 2.3//EN
"http://java.sun.com dt d/ web-app_2_3. dtd">
<web- app>
<di spl ay- name>Cayenne Tutori al </ di spl ay- name>

<l-- This filter bootstraps ServerRuntime and then provi des each request thread
with a session-bound DataContext. Note that the nane of the filter is inportant,
as it points it to the right named configuration file.
-->
<filter>
<filter-name>cayenne-project</filter-name>
<filter-class>org. apache. cayenne. configuration. web. CayenneFilter</filter-class>
</filter>
<filter-nmappi ng>
<filter-name>cayenne-project</filter-name>
<url-pattern>/*</url-pattern>
</filter-mappi ng>
<wel cone-file-list>
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to aWeb Application

<wel come-fil e>i ndex. j sp</wel come-fil e>
</wel come-file-list>
</ web- app>

Create the artist browser page src/main/webapp/index.jsp file with the following contents:

webapp/index.jsp

<% page | anguage="j ava" content Type="text/htm" %
<%@ page i nport="org.exanpl e. cayenne. persi stent.*" %
<% page i nport="org. apache. cayenne. *" %

<%@ page i nport="org.apache. cayenne. query.*" %

<%@ page i nport="org. apache. cayenne. exp.*" %

<% page inport="java.util.*" %

<%
Sel ect Query query = new Sel ect Query(Artist.class);
query. addOrderi ng(Artist. NAME_PROPERTY, Sort O der. ASCENDI NG ;

bj ect Cont ext context = BaseContext. get Thr eadCbj ect Cont ext () ;
List<Artist> artists = context.perfornmuery(query);

%
<htm >
<head>
<title>Main</title>
</ head>
<body>
<h2>Artists: </ h2>
<%if(artists.isEmty()) {%
<p>No artists found</p>
<%} else {
for(Artist a : artists) {
%
<p><a href="detail.jsp?i d=<¥%Cayenne. i nt PKFor Cbj ect (a) %" > <%a. get Nane() % </ a></p>
<%
}
} %
<hr>
<p><a href="detail.jsp">Create new artist...</a></p>
</ body>
</htnm >

Create the artist editor page src/main/webapp/detail .jsp with the following content:

webapp/detail.jsp

<%@ page | anguage="j ava" content Type="text/htm" %
<%@ page i nport="org.exanpl e. cayenne. persi stent.*" %
<% page i nport="org. apache. cayenne. *" %

<% page inport="java.util.*" %

<%@ page inport="java.text.*" %

<%
bj ect Cont ext context = BaseContext. get Thr eadCbj ect Cont ext () ;
String id = request.getParanmeter("id");

/1l find artist for id
Artist artist = null;
if(id!=null & id.trinm().length() > 0) {
artist = Cayenne. obj ect For PK(context, Artist.class, Integer.parselnt(id));
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i f("POST". equal s(request.get Method())) {
/1 if noidis saved in the hidden field, we are dealing with
I/ create new artist request
if(artist == null) {
artist = context.new(bject(Artist.class);

/1 note that in a real application we would so done validation ...
/Il here we just hope the input is correct

artist.set Name(request. get Paraneter("nanme"));
artist.setDateOrBirthString(request.getParanmeter("dateOdBirth"));

cont ext. comm t Changes();

response. sendRedi rect ("i ndex. j sp");

}
if(artist == null) {
Il create transient artist for the formresponse rendering
artist = new Artist();
}
String name = artist.getNane() == null ? "" : artist.getName();
String dob = artist.getDateOBirth() == null
? "" : new Sinpl eDat eFormat ("yyyyMwdd") . format (artist.getDateOBirth());
%
<htm >
<head>
<title>Artist Details</title>
</ head>
<body>
<h2>Artists Detail s</h2>
<form name="Edi t Artist" action="detail.jsp" method="POST">
<i nput type="hidden" name="id" value="<% id !=null ?2id: "" %" />
<t abl e border="0">
<tr>
<t d>Nane: </ t d>
<t d><i nput type="text" name="nane" val ue="<% nane %"/></td>
</tr>
<tr>
<td>Date of Birth (yyyymMwd):</td>
<td><i nput type="text" name="dateOfBirth" value="<% dob %"/></td>
</tr>
<tr>
<td></td>
<td align="right"><input type="submit" val ue="Save" /></td>
</tr>
</ tabl e>
</form
</ body>
</htm >

Running Web Application

To run the web application we'll use "maven-jetty-plugin®. To activate it, let's add the following piece of
code to the "pom.xml" file, following the "dependencies" section and save the POM:

<bui | d>
<pl ugi ns>
<pl ugi n>
<groupl d>or g. nortbay. j etty</ groupl d>
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<artifactld>maven-jetty-plugin</artifactld>
<ver si on>6. 1. 22</ ver si on>
</ pl ugi n>
</ pl ugi ns>
</ bui | d>

» Go to "Run > Run Configurations..." menu, select "Maven Build", right click and select "New"

» Makesureyou fill "Name", "Base directory" and "Goals' fields as shown on the screenshot:

8.N0 Run Configurations

Create, manage, and run configurations

>

- = L

=R | [ 5o Name:  cayenne-tutorial

type filter text E| Main =i JRE Qéh Refresh E Environment | =] Comman
E Apache Tomcat Base directory:

& Eclipse Application
E4 Eclipse Data Tools

E Ceneric Server [ Browse Workspace... )
E Generic Server{External Launch)
E HTTP Preview

[ J2EE Preview

${workspace_loc: /tutorial}

- = S - N
[ Browse File System... | [ Variables... )

———
Goals:  jetty:run| [ Select... )

il Java Applet Profiles:

T1Java Application

Ju JUnit ] Offline ] Update Snapshots

J

T Junit Flug-in Test ] Debug Output [ Skip Tests  [_| Non-recursive

m2 Maven Build

] Resolve Workspace artifacts
m2 cayenne-tutorial

ﬁ)osci Framework |Parameter Name Value | "T"
Juy Task Context Test
>4 ASL Edit..
Remove
Maven Runtime: | Embedded (3.0-SNAPSHOT/0.12.1.20110112-1712) 3] (Configure... )

Apply Revert
Filter matched 16 of 16 items
@:l ( Close :, ( Run )

» Click "Apply" and "Run". On the first execution it may take afew minutes for Jetty plugin to download all
dependencies, but eventually you'll see the logs like this:

[INFO Scanning for projects...

[ I NFO

[ RO I e R R TR
[INFG Building tutorial 0.0.1-SNAPSHOT

[N R I e R

[INFO Configuring Jetty for project: tutorial

[INFO Webapp source directory = /.../tutorial/src/min/webapp
[INFO Rel oad Mechanic: automatic

[INFO Classes = /.../tutorial/target/classes

[INFO Context path = /tutorial

[INFQ Tnp directory = determned at runtine

[INFO Wb defaults = org/nortbay/jetty/ webapp/ webdefaul t.xn
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[INFO Web overrides = none

[INFO web.xm file =/.../tutorial/src/ min/webapp/VEB-|NF/ web. xmn

[INFO Webapp directory = /.../tutorial/src/main/webapp

[INFQ Starting jetty 6.1.22 ...

INFO :jetty-6.1.22

I NFO : No Transaction nmanager found - if your webapp requires one, please configure one.
INFQO : Started Sel ect Channel Connect or @. 0. 0. 0: 8080

[INFO Started Jetty Server

So the Jetty container just started.

Now go to http://localhost: 8080/tutorial/ URL. Y ou should see "No artists found message” in the web
browser and the following output in the Eclipse console:

I NFO Loading XM. configuration resource fromfile:/.../tutorial/target/classes/cayenne-project.xnl
I NFO. | oadi ng user nane and password.
INFO. Created connection pool: jdbc:derby: nenory:testdb;create=true

Driver class: org.apache. derby.jdbc. EnbeddedDri ver

M n. connections in the pool: 1

Max. connections in the pool: 1
I NFO. Openi ng connection: jdbc:derby: nenory:testdb;create=true

Logi n: nul |

Passwor d: ***xx**
I NFO. +++ Connecting: SUCCESS.
INFO. Detected and installed adapter: org.apache. cayenne. dba. der by. Der byAdapt er
INFO --- transaction started.
INFO. No schema detected, will create nmapped tables
I NFO. CREATE TABLE GALLERY (1D I NTEGER NOT NULL, NAME VARCHAR (200), PRI MARY KEY (1D))
| NFO. CREATE TABLE ARTI ST (DATE_OF_BI RTH DATE, | D I NTEGER NOT NULL, NAME VARCHAR (200), PRI MARY KEY (1D))
I NFO CREATE TABLE PAINTI NG (ARTI ST_I D | NTEGER, GALLERY_I D I NTEGER, | D | NTEGER NOT NULL,

NAVE VARCHAR (200), PRI MARY KEY (1D))
I NFO. ALTER TABLE PAI NTI NG ADD FOREI GN KEY (ARTI ST_I D) REFERENCES ARTI ST (1 D)
I NFO. ALTER TABLE PAI NTI NG ADD FOREI GN KEY (GALLERY_|I D) REFERENCES GALLERY (1 D)
I NFO CREATE TABLE AUTO_PK_SUPPORT (
TABLE_NAVE CHAR(100) NOT NULL, NEXT_ID BI G NT NOT NULL, PRI MARY KEY( TABLE_NAME))

| NFO. DELETE FROM AUTO PK_SUPPORT WHERE TABLE_NAME I N (' ARTI ST', ' GALLERY', 'PAINTING )
INFO | NSERT | NTO AUTO PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES (' ARTIST', 200)
INFO | NSERT | NTO AUTO_PK_SUPPORT ( TABLE_NAME, NEXT_I D) VALUES (' GALLERY', 200)
I NFO. | NSERT | NTO AUTO PK_SUPPORT ( TABLE_NAME, NEXT_I D) VALUES (' PAINTING , 200)
I NFO. SELECT t 0. DATE_OF_BIRTH, t0.NAME, tO0.1D FROM ARTI ST t0 ORDER BY t0. NAME - prepared in 43 ns.
INFO === returned O rows. - took 56 ms.
INFO +++ transaction conmitted.

You can click on "Create new artist" link to create artists. Existing artists can be edited by clicking on
their name:



Running Web Application

(€ ) » )= (@) % ) () (B np://127.0.0.1:8080/ tutorial/index.jsp

Artists:

Malevich

Picasso

Create new artist...

Y ou are done with the tutorial!
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